CVE-2009-1482

NameCVE-2009-1482
DescriptionMultiple cross-site scripting (XSS) vulnerabilities in action/AttachFile.py in MoinMoin 1.8.2 and earlier allow remote attackers to inject arbitrary web script or HTML via (1) an AttachFile sub-action in the error_msg function or (2) multiple vectors related to package file errors in the upload_form function, different vectors than CVE-2009-0260.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1791-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs526594
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
moin (PTS)squeeze1.9.3-1+squeeze5fixed
squeeze (security)1.9.3-1+squeeze4fixed
wheezy1.9.4-8+deb7u2fixed
stretch, sid, jessie1.9.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
moinsource(unstable)1.8.3-1low526594
moinsourceetch(not affected)
moinsourcelenny1.7.1-3+lenny2mediumDSA-1791-1

Notes

[etch] - moin <not-affected> (Not exploitable)
http://hg.moinmo.in/moin/1.8/rev/5f51246a4df1

Search for package or bug name: Reporting problems