CVE-2009-1630

NameCVE-2009-1630
DescriptionThe nfs_permission function in fs/nfs/dir.c in the NFS client implementation in the Linux kernel 2.6.29.3 and earlier, when atomic_open is available, does not check execute (aka EXEC or MAY_EXEC) permission bits, which allows local users to bypass permissions and execute files, as demonstrated by files on an NFSv4 fileserver.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1809-1, DSA-1844-1, DSA-1865-1
NVD severitymedium (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze, squeeze (security)2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
fai-kernelssourceetch1.17+etch.24etch3mediumDSA-1865-1
linux-2.6source(unstable)2.6.30-1medium
linux-2.6sourceetch2.6.18.dfsg.1-24etch3mediumDSA-1865-1
linux-2.6sourcelenny2.6.26-15lenny3mediumDSA-1809-1
linux-2.6.24source(unstable)(unfixed)medium
linux-2.6.24sourceetch2.6.24-6~etchnhalf.8etch2mediumDSA-1844-1
user-mode-linuxsourceetch2.6.18-1um-2etch.24etch3mediumDSA-1865-1
user-mode-linuxsourcelenny2.6.26-1um-2+15lenny3mediumDSA-1809-1

Search for package or bug name: Reporting problems