CVE-2009-1684

NameCVE-2009-1684
DescriptionCross-site scripting (XSS) vulnerability in WebKit in Apple Safari before 4.0, iPhone OS 1.0 through 2.2.1, and iPhone OS for iPod touch 1.1 through 2.2.1 allows remote attackers to inject arbitrary web script or HTML via an event handler that triggers script execution in the context of the next loaded document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1950-1
NVD severitymedium
Debian Bugs535793

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde4libs (PTS)stretch4:4.14.26-2fixed
buster4:4.14.38-3fixed
qt4-x11 (PTS)stretch4:4.8.7+dfsg-11fixed
stretch (security)4:4.8.7+dfsg-11+deb9u1fixed
buster4:4.8.7+dfsg-18+deb10u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kde4libssource(unstable)(not affected)
kdelibssource(unstable)(not affected)
qt4-x11source(unstable)4:4.6.2-4low
webkitsourcelenny1.0.1-4+lenny2DSA-1950-1
webkitsource(unstable)1.1.12-1low535793

Notes

[lenny] - qt4-x11 <no-dsa> (qtwebkit not supported security-wise)
QT4 might be fixed earlier, but only 4.6.2 was checked against
http://trac.webkit.org/changeset/42365

Search for package or bug name: Reporting problems