CVE-2009-1686

NameCVE-2009-1686
DescriptionWebKit in Apple Safari before 4.0, iPhone OS 1.0 through 2.2.1, and iPhone OS for iPod touch 1.1 through 2.2.1 does not properly handle constant (aka const) declarations in a type-conversion operation during JavaScript exception handling, which allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted HTML document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs535793

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde4libs (PTS)jessie4:4.14.2-5+deb8u2fixed
jessie (security)4:4.14.2-5+deb8u3fixed
stretch4:4.14.26-2fixed
buster4:4.14.38-3fixed
qt4-x11 (PTS)jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
jessie (security)4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u2fixed
stretch4:4.8.7+dfsg-11fixed
buster4:4.8.7+dfsg-18fixed
bullseye, sid4:4.8.7+dfsg-19fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kde4libssource(unstable)(not affected)
kdelibssource(unstable)(not affected)
qt4-x11source(unstable)4:4.6.2-4
webkitsource(unstable)1.1.12-1medium535793
webkitsourcelenny(not affected)

Notes

[lenny] - webkit <not-affected> (Vulnerable code not present)
[lenny] - qt4-x11 <no-dsa> (qtwebkit not supported security-wise)
QT4 might be fixed earlier, but only 4.6.2 was checked against
http://trac.webkit.org/changeset/31431

Search for package or bug name: Reporting problems