CVE-2009-1688

NameCVE-2009-1688
DescriptionCross-site scripting (XSS) vulnerability in WebKit in Apple Safari before 4.0, iPhone OS 1.0 through 2.2.1, and iPhone OS for iPod touch 1.1 through 2.2.1 allows remote attackers to inject arbitrary web script or HTML via vectors related to determining a security context through an approach that is not the "HTML 5 standard method."
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs535793

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde4libs (PTS)jessie (security), jessie4:4.14.2-5+deb8u2fixed
stretch4:4.14.26-2fixed
buster, sid4:4.14.38-1fixed
qt4-x11 (PTS)jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
stretch4:4.8.7+dfsg-11fixed
buster, sid4:4.8.7+dfsg-17fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kde4libssource(unstable)(not affected)
kdelibssource(unstable)(not affected)
qt4-x11source(unstable)4.4.3-1medium
webkitsource(unstable)1.1.12-1low535793
webkitsourcelenny(not affected)

Notes

[lenny] - webkit <not-affected> (Vulnerable code not present)
QT4 might be fixed earlier, but only Lenny version was checked
http://trac.webkit.org/changeset/32791

Search for package or bug name: Reporting problems