CVE-2009-1695

NameCVE-2009-1695
DescriptionCross-site scripting (XSS) vulnerability in WebKit in Apple Safari before 4.0, iPhone OS 1.0 through 2.2.1, and iPhone OS for iPod touch 1.1 through 2.2.1 allows remote attackers to inject arbitrary web script or HTML via vectors involving access to frame contents after completion of a page transition.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1950-1
NVD severitymedium (attack range: remote)
Debian Bugs535793

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde4libs (PTS)wheezy4:4.8.4-4+deb7u1fixed
wheezy (security)4:4.8.4-4+deb7u3fixed
jessie (security), jessie4:4.14.2-5+deb8u2fixed
stretch4:4.14.26-2fixed
buster, sid4:4.14.36-1fixed
qt4-x11 (PTS)wheezy4:4.8.2+dfsg-11fixed
jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
buster, sid, stretch4:4.8.7+dfsg-11fixed
webkit (PTS)wheezy1.8.1-3.4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kde4libssource(unstable)(not affected)
kdelibssource(unstable)(not affected)
qt4-x11source(unstable)4:4.6.2-4low
qt4-x11sourcelenny(not affected)
webkitsource(unstable)1.1.12-1low535793
webkitsourcelenny1.0.1-4+lenny2mediumDSA-1950-1

Notes

[lenny] - qt4-x11 <not-affected> (Vulnerable code not present)
QT4 might be fixed earlier, but only 4.6.2 was checked against
http://trac.webkit.org/changeset/42223

Search for package or bug name: Reporting problems