CVE-2009-1721

NameCVE-2009-1721
DescriptionThe decompression implementation in the Imf::hufUncompress function in OpenEXR 1.2.2 and 1.6.1 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via vectors that trigger a free of an uninitialized pointer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1842-1
Debian Bugs540424

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openexr (PTS)buster2.2.1-4.1+deb10u1fixed
buster (security)2.2.1-4.1+deb10u2fixed
bullseye (security), bullseye2.5.4-2+deb11u1fixed
bookworm3.1.5-5fixed
trixie, sid3.1.5-5.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openexrsourceetch1.2.2-4.3+etch2DSA-1842-1
openexrsourcelenny1.6.1-3+lenny3DSA-1842-1
openexrsource(unstable)1.6.1-4.1medium540424

Search for package or bug name: Reporting problems