CVE-2009-1788

NameCVE-2009-1788
DescriptionHeap-based buffer overflow in voc_read_header in libsndfile 1.0.15 through 1.0.19, as used in Winamp 5.552 and possibly other media programs, allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via a VOC file with an invalid header value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1814-1, DTSA-202-1
NVD severityhigh (attack range: remote)
Debian Bugs528650

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)wheezy1.0.25-5fixed
wheezy (security)1.0.25-9.1+deb7u4fixed
jessie1.0.25-9.1+deb8u1fixed
stretch1.0.27-3fixed
buster, sid1.0.28-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesource(unstable)1.0.20-1low528650
libsndfilesourceetch1.0.16-2+etch2highDSA-1814-1
libsndfilesourcelenny1.0.17-4+lenny2highDSA-1814-1
libsndfilesourcesqueeze1.0.18-2+squeeze1highDTSA-202-1

Search for package or bug name: Reporting problems