CVE-2009-1791

NameCVE-2009-1791
DescriptionHeap-based buffer overflow in aiff_read_header in libsndfile 1.0.15 through 1.0.19, as used in Winamp 5.552 and possibly other media programs, allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via an AIFF file with an invalid header value.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1814-1, DTSA-202-1
Debian Bugs528650

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)buster1.0.28-6+deb10u1fixed
buster (security)1.0.28-6+deb10u2fixed
bullseye1.0.31-2fixed
bookworm, sid1.1.0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesourceetch1.0.16-2+etch2DSA-1814-1
libsndfilesourcelenny1.0.17-4+lenny2DSA-1814-1
libsndfilesourcesqueeze1.0.18-2+squeeze1DTSA-202-1
libsndfilesource(unstable)1.0.20-1low528650

Search for package or bug name: Reporting problems