CVE-2009-1886

NameCVE-2009-1886
DescriptionMultiple format string vulnerabilities in client/client.c in smbclient in Samba 3.2.0 through 3.2.12 might allow context-dependent attackers to execute arbitrary code via format string specifiers in a filename.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1823-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
samba (PTS)squeeze (security), squeeze2:3.5.6~dfsg-3squeeze11fixed
squeeze (lts)2:3.5.6~dfsg-3squeeze12fixed
wheezy2:3.6.6-6+deb7u4fixed
wheezy (security)2:3.6.6-6+deb7u5fixed
jessie, sid2:4.1.17+dfsg-1fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sambasource(unstable)2:3.3.6-1high
sambasourceetch(not affected)
sambasourcelenny2:3.2.5-4lenny6highDSA-1823-1

Notes

[etch] - samba <not-affected> (Vulnerable code not present)
Only the 3.2.x branch was affected, so marking 3.3 as affected

Search for package or bug name: Reporting problems