CVE-2009-1892

NameCVE-2009-1892
Descriptiondhcpd in ISC DHCP 3.0.4 and 3.1.1, when the dhcp-client-identifier and hardware ethernet configuration settings are both used, allows remote attackers to cause a denial of service (daemon crash) via unspecified requests.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1833-2
NVD severitymedium (attack range: remote)
Debian Bugs539492, 549584
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
isc-dhcp (PTS)squeeze (security), squeeze4.1.1-P1-15+squeeze8fixed
wheezy4.2.2.dfsg.1-5+deb70u6fixed
jessie, sid4.3.1-6fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dhcp3source(unstable)3.1.2p1-2low549584
dhcp3sourceetch(not affected)
dhcp3sourcelenny3.1.1-6+lenny3mediumDSA-1833-2
isc-dhcpsource(unstable)3.1.2p1-2low539492

Notes

[etch] - dhcp3 <not-affected> (problematic assert is not present)

Search for package or bug name: Reporting problems