CVE-2009-1955

NameCVE-2009-1955
DescriptionThe expat XML parser in the apr_xml_* interface in xml/apr_xml.c in Apache APR-util before 1.3.7, as used in the mod_dav and mod_dav_svn modules in the Apache HTTP Server, allows remote attackers to cause a denial of service (memory consumption) via a crafted XML document containing a large number of nested entity references, as demonstrated by a PROPFIND request, a similar issue to CVE-2003-1564.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1812-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apr-util (PTS)jessie1.5.4-1fixed
stretch1.5.4-3fixed
bullseye, sid, buster1.6.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apr-utilsource(unstable)1.3.7+dfsg-1medium
apr-utilsourceetch1.2.7+dfsg-2+etch2DSA-1812-1
apr-utilsourcelenny1.2.12+dfsg-8+lenny2DSA-1812-1

Search for package or bug name: Reporting problems