CVE-2009-1956

NameCVE-2009-1956
DescriptionOff-by-one error in the apr_brigade_vprintf function in Apache APR-util before 1.3.5 on big-endian platforms allows remote attackers to obtain sensitive information or cause a denial of service (application crash) via crafted input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apr-util (PTS)buster1.6.1-4fixed
buster (security)1.6.1-4+deb10u1fixed
bullseye1.6.1-5fixed
bullseye (security)1.6.1-5+deb11u1fixed
bookworm, sid1.6.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apr-utilsourcelenny1.2.12+dfsg-8+lenny3
apr-utilsource(unstable)1.3.7+dfsg-1low

Search for package or bug name: Reporting problems