CVE-2009-2185

NameCVE-2009-2185
DescriptionThe ASN.1 parser (pluto/asn1.c, libstrongswan/asn1/asn1.c, libstrongswan/asn1/asn1_parser.c) in (a) strongSwan 2.8 before 2.8.10, 4.2 before 4.2.16, and 4.3 before 4.3.2; and (b) openSwan 2.6 before 2.6.22 and 2.4 before 2.4.15 allows remote attackers to cause a denial of service (pluto IKE daemon crash) via an X.509 certificate with (1) crafted Relative Distinguished Names (RDNs), (2) a crafted UTCTIME string, or (3) a crafted GENERALIZEDTIME string.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1898-1, DSA-1899-1
NVD severitymedium (attack range: remote)
Debian Bugs533837
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openswan (PTS)squeeze (security)1:2.6.28+dfsg-5+squeeze2fixed
wheezy1:2.6.37-3fixed
wheezy (security)1:2.6.37-3+deb7u1fixed
strongswan (PTS)squeeze, squeeze (security)4.4.1-5.6fixed
wheezy4.5.2-1.5+deb7u4fixed
wheezy (security)4.5.2-1.5+deb7u6fixed
stretch, sid, jessie5.2.1-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openswansource(unstable)1:2.6.22+dfsg-1medium
openswansourceetch1:2.4.6+dfsg.2-1.1+etch2mediumDSA-1898-1
openswansourcelenny1:2.4.12+dfsg-1.3+lenny2mediumDSA-1898-1
strongswansource(unstable)4.2.14-1.2medium533837
strongswansourceetch2.8.0+dfsg-1+etch2mediumDSA-1899-1
strongswansourcelenny4.2.4-5+lenny3mediumDSA-1899-1

Search for package or bug name: Reporting problems