CVE-2009-2195

NameCVE-2009-2195
DescriptionBuffer overflow in WebKit in Apple Safari before 4.0.3 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via crafted floating-point numbers.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde4libs (PTS)jessie4:4.14.2-5+deb8u2fixed
jessie (security)4:4.14.2-5+deb8u3fixed
stretch4:4.14.26-2fixed
buster4:4.14.38-3fixed
qt4-x11 (PTS)jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
jessie (security)4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u2fixed
stretch4:4.8.7+dfsg-11fixed
buster4:4.8.7+dfsg-18fixed
bullseye, sid4:4.8.7+dfsg-19fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kde4libssource(unstable)(not affected)
kdelibssource(unstable)(not affected)
qt4-x11source(unstable)(not affected)
webkitsource(unstable)1.1.12-1medium
webkitsourcelenny(not affected)

Notes

[lenny] - webkit <not-affected> (Vulnerable code not present)
https://bugzilla.redhat.com/show_bug.cgi?id=517273
http://trac.webkit.org/changeset/45696

Search for package or bug name: Reporting problems