CVE-2009-2210

NameCVE-2009-2210
DescriptionMozilla Thunderbird before 2.0.0.22 and SeaMonkey before 1.1.17 allow remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a multipart/alternative e-mail message containing a text/enhanced part that triggers access to an incorrect object type.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1830-1
NVD severityhigh (attack range: remote)
Debian Bugs535124

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
icedove (PTS)jessie1:52.3.0-4~deb8u2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
iceapesource(unstable)1.1.17-1high
iceapesourceetch(unfixed)end-of-life
iceapesourcelenny(not affected)
iceapesourcesqueeze(not affected)
icedovesource(unstable)2.0.0.22-1high535124
icedovesourcelenny2.0.0.22-0lenny1highDSA-1830-1
icedovesourcesqueeze2.0.0.22-0lenny1high
kompozersource(unstable)(not affected)

Notes

[squeeze] - iceape <not-affected> (only provides a stub for XPCOM)
[lenny] - iceape <not-affected> (Only provides a stub for XPCOM)
[etch] - iceape <end-of-life> (Etch Packages no longer covered by security support)
- kompozer <not-affected> (mail suite not compiled)
http://www.mozilla.org/security/announce/2009/mfsa2009-33.html
https://bugzilla.mozilla.org/show_bug.cgi?id=495057

Search for package or bug name: Reporting problems