CVE-2009-2281

NameCVE-2009-2281
DescriptionMultiple heap-based buffer underflows in the readPostBody function in cgiutil.c in mapserv in MapServer 4.x through 4.10.4 and 5.x before 5.4.2 allow remote attackers to execute arbitrary code via (1) a crafted Content-Length HTTP header or (2) a large HTTP request, related to an integer overflow that triggers a heap-based buffer overflow. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2009-0840.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1914-1
NVD severityhigh (attack range: remote)
Debian Bugs535340

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mapserver (PTS)wheezy6.0.1-3.2+deb7u2fixed
wheezy (security)6.0.1-3.2+deb7u4fixed
jessie (security), jessie6.4.1-5+deb8u3fixed
stretch7.0.4-2fixed
buster, sid7.0.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mapserversource(unstable)5.4.2-1medium535340
mapserversourceetch4.10.0-5.1+etch4highDSA-1914-1
mapserversourcelenny5.0.3-3+lenny4highDSA-1914-1

Notes

http://www.openwall.com/lists/oss-security/2009/06/22/2

Search for package or bug name: Reporting problems