CVE-2009-2347

NameCVE-2009-2347
DescriptionMultiple integer overflows in inter-color spaces conversion tools in libtiff 3.8 through 3.8.2, 3.9, and 4.0 allow context-dependent attackers to execute arbitrary code via a TIFF image with large (1) width and (2) height values, which triggers a heap-based buffer overflow in the (a) cvt_whole_image function in tiff2rgba and (b) tiffcvt function in rgb2ycbcr.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1835-1
NVD severityhigh (attack range: remote, user-initiated)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tiff (PTS)squeeze, squeeze (security)3.9.4-5+squeeze10fixed
squeeze (lts)3.9.4-5+squeeze12fixed
wheezy4.0.2-6+deb7u3fixed
wheezy (security)4.0.2-6+deb7u4fixed
jessie4.0.3-12.3fixed
stretch4.0.3-13fixed
sid4.0.5-1fixed
tiff3 (PTS)wheezy3.9.6-11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tiffsource(unstable)3.8.2-13high
tiffsourceetch3.8.2-7+etch3highDSA-1835-1
tiffsourcelenny3.8.2-11.2highDSA-1835-1
tiff3source(unstable)(not affected)

Notes

- tiff3 <not-affected> (fixed prior to initial upload)

Search for package or bug name: Reporting problems