CVE-2009-2411

NameCVE-2009-2411
DescriptionMultiple integer overflows in the libsvn_delta library in Subversion before 1.5.7, and 1.6.x before 1.6.4, allow remote authenticated users and remote Subversion servers to execute arbitrary code via an svndiff stream with large windows that trigger a heap-based buffer overflow, a related issue to CVE-2009-2412.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1855-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
subversion (PTS)wheezy1.6.17dfsg-4+deb7u10fixed
wheezy (security)1.6.17dfsg-4+deb7u12fixed
jessie (security), jessie1.8.10-6+deb8u5fixed
stretch (security), stretch1.9.5-1+deb9u1fixed
buster1.9.7-2fixed
sid1.9.7-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
subversionsource(unstable)1.6.4dfsg-1high
subversionsourceetch1.4.2dfsg1-3highDSA-1855-1
subversionsourcelenny1.5.1dfsg1-4highDSA-1855-1

Search for package or bug name: Reporting problems