DescriptionSquid 3.0 through 3.0.STABLE16 and 3.1 through does not properly enforce "buffer limits and related bound checks," which allows remote attackers to cause a denial of service via (1) an incomplete request or (2) a request with a large header size, related to (a) and (b)
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1843-1, DSA-1843-2
NVD severitymedium (attack range: remote)
Debian Bugs538989

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squid (PTS)wheezy2.7.STABLE9-4.1+deb7u1fixed
wheezy (security)2.7.STABLE9-4.1+deb7u3fixed
squid3 (PTS)wheezy3.1.20-2.2+deb7u4fixed
wheezy (security)3.1.20-2.2+deb7u8fixed
jessie (security)3.4.8-6+deb8u5fixed
stretch (security), stretch3.5.23-5+deb9u1fixed
buster, sid3.5.27-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squidsource(unstable)(not affected)
squidsourceetch(not affected)DSA-1843-1


- squid <not-affected> (see NOTE)
squid 2.x not affected, according to

Search for package or bug name: Reporting problems