CVE-2009-2629

NameCVE-2009-2629
DescriptionBuffer underflow in src/http/ngx_http_parse.c in nginx 0.1.0 through 0.5.37, 0.6.x before 0.6.39, 0.7.x before 0.7.62, and 0.8.x before 0.8.15 allows remote attackers to execute arbitrary code via crafted HTTP requests.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1884-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nginx (PTS)wheezy1.2.1-2.2+wheezy4fixed
wheezy (security)1.2.1-2.2+wheezy4+deb7u1fixed
jessie1.6.2-5+deb8u4fixed
jessie (security)1.6.2-5+deb8u5fixed
stretch (security), stretch1.10.3-1+deb9u1fixed
buster, sid1.13.6-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
nginxsource(unstable)0.7.61-3medium
nginxsourceetch0.4.13-2+etch2highDSA-1884-1
nginxsourcelenny0.6.32-3+lenny2highDSA-1884-1

Search for package or bug name: Reporting problems