CVE-2009-2658

NameCVE-2009-2658
DescriptionDirectory traversal vulnerability in ZNC before 0.072 allows remote attackers to overwrite arbitrary files via a crafted DCC SEND request.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1848-1
NVD severityhigh
Debian Bugs537977

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
znc (PTS)stretch (security), stretch1.6.5-1+deb9u2fixed
buster1.7.2-3fixed
bullseye, sid1.8.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
zncsourceetch0.045-3+etch3DSA-1848-1
zncsourcelenny0.058-2+lenny3DSA-1848-1
zncsource(unstable)0.074-1medium537977

Notes

http://znc.svn.sourceforge.net/viewvc/znc?view=rev&sortby=rev&sortdir=down&revision=1570
CVE id requested

Search for package or bug name: Reporting problems