CVE-2009-2661

NameCVE-2009-2661
DescriptionThe asn1_length function in strongSwan 2.8 before 2.8.11, 4.2 before 4.2.17, and 4.3 before 4.3.3 does not properly handle X.509 certificates with crafted Relative Distinguished Names (RDNs), which allows remote attackers to cause a denial of service (pluto IKE daemon crash) via malformed ASN.1 data. NOTE: this is due to an incomplete fix for CVE-2009-2185.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1899-1
NVD severitymedium (attack range: remote)
Debian Bugs540144
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
strongswan (PTS)squeeze, squeeze (security)4.4.1-5.6fixed
squeeze (lts)4.4.1-5.7fixed
wheezy4.5.2-1.5+deb7u4fixed
wheezy (security)4.5.2-1.5+deb7u7fixed
jessie5.2.1-6fixed
jessie (security)5.2.1-6+deb8u1fixed
stretch, sid5.3.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
strongswansource(unstable)4.3.2-1.1medium540144
strongswansourceetch2.8.0+dfsg-1+etch2mediumDSA-1899-1
strongswansourcelenny4.2.4-5+lenny3mediumDSA-1899-1

Search for package or bug name: Reporting problems