CVE-2009-2687

NameCVE-2009-2687
DescriptionThe exif_read_data function in the Exif module in PHP before 5.2.10 allows remote attackers to cause a denial of service (crash) via a malformed JPEG image with invalid offset fields, a different issue than CVE-2005-3353.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1940-1
NVD severitymedium (attack range: remote, user-initiated)
Debian Bugs535888, 535897
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze (security), squeeze5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3-7+squeeze25fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.36-0+deb7u3fixed
jessie, sid5.6.6+dfsg-2fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php4source(unstable)(unfixed)low535897
php5source(unstable)5.2.10.dfsg.1-2low535888
php5sourceetch5.2.0+dfsg-8+etch16mediumDSA-1940-1
php5sourcelenny5.2.6.dfsg.1-1+lenny4mediumDSA-1940-1

Notes

5.3.0 (in experimental) is not affected

Search for package or bug name: Reporting problems