CVE-2009-2694

NameCVE-2009-2694
DescriptionThe msn_slplink_process_msg function in libpurple/protocols/msn/slplink.c in libpurple, as used in Pidgin (formerly Gaim) before 2.5.9 and Adium 1.3.5 and earlier, allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) by sending multiple crafted SLP (aka MSNSLP) messages to trigger an overwrite of an arbitrary memory location. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2009-1376.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1870-1
NVD severityhigh (attack range: remote)
Debian Bugs542486
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pidgin (PTS)squeeze (security), squeeze2.7.3-1+squeeze4fixed
wheezy, wheezy (security)2.10.10-1~deb7u1fixed
jessie, sid2.10.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gaimsource(unstable)(unfixed)high
gaimsourcelenny(not affected)
pidginsource(unstable)2.5.9-1medium542486
pidginsourcelenny2.4.3-4lenny3highDSA-1870-1

Notes

[lenny] - gaim <not-affected> (Only a transitional package)

Search for package or bug name: Reporting problems