CVE-2009-2695

NameCVE-2009-2695
DescriptionThe Linux kernel before 2.6.31-rc7 does not properly prevent mmap ...
SourceCVE (at NVD; oss-sec, OSVDB, EDB, Red Hat, Ubuntu, Gentoo, SuSE, more)
ReferencesDSA-1915-1, DSA-2005-1
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze, squeeze (security)2.6.32-48squeeze4fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6source(unstable)2.6.31-1medium
linux-2.6sourceetch(not affected)
linux-2.6sourcelenny2.6.26-19lenny1DSA-1915-1
linux-2.6.24source(unstable)(unfixed)medium
linux-2.6.24sourceetch2.6.24-6~etchnhalf.9etch3DSA-2005-1

Notes

[etch] - linux-2.6 <not-affected> (2.6.18 does not have mmap_min_addr)

Search for package or bug name: Reporting problems

Home - Testing Security Team - Debian Security - Source (SVN)