CVE-2009-2816

NameCVE-2009-2816
DescriptionThe implementation of Cross-Origin Resource Sharing (CORS) in WebKit, as used in Apple Safari before 4.0.4 and Google Chrome before 3.0.195.33, includes certain custom HTTP headers in the OPTIONS request during cross-origin operations with preflight, which makes it easier for remote attackers to conduct cross-site request forgery (CSRF) attacks via a crafted web page.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs559759

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde4libs (PTS)jessie4:4.14.2-5+deb8u2fixed
jessie (security)4:4.14.2-5+deb8u3fixed
stretch4:4.14.26-2fixed
buster4:4.14.38-3fixed
qt4-x11 (PTS)jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
jessie (security)4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u2fixed
stretch4:4.8.7+dfsg-11fixed
buster4:4.8.7+dfsg-18fixed
bullseye, sid4:4.8.7+dfsg-19fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kde4libssource(unstable)(not affected)
kdelibssource(unstable)(not affected)
qt4-x11source(unstable)4:4.6.2-4low
qt4-x11sourcelenny(not affected)
webkitsource(unstable)1.1.21-1low559759
webkitsourcelenny(not affected)

Notes

[lenny] - webkit <not-affected> (vulnerable code not present)
QT4 might be fixed earlier, but only 4.6.2 was checked against
[lenny] - qt4-x11 <not-affected> (Vulnerable code not present)
http://trac.webkit.org/changeset/47494

Search for package or bug name: Reporting problems