CVE-2009-2905

NameCVE-2009-2905
DescriptionHeap-based buffer overflow in textbox.c in newt 0.51.5, 0.51.6, and 0.52.2 allows local users to cause a denial of service (application crash) or possibly execute arbitrary code via a request to display a crafted text dialog box.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1894-1
NVD severitymedium (attack range: local)
Debian Bugs548198

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
newt (PTS)wheezy0.52.14-11.1fixed
jessie0.52.17-1fixed
stretch0.52.19-1fixed
buster, sid0.52.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
newtsource(unstable)0.52.10-4.1medium548198
newtsourceetch0.52.2-10+etch1mediumDSA-1894-1
newtsourcelenny0.52.2-11.3+lenny1mediumDSA-1894-1

Search for package or bug name: Reporting problems