CVE-2009-2942

NameCVE-2009-2942
DescriptionThe mysql-ocaml bindings 1.0.4 for MySQL do not properly support the mysql_real_escape_string function, which might allow remote attackers to leverage escaping issues involving multibyte character encodings.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1910-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mysql-ocaml (PTS)wheezy1.1.1-1fixed
jessie1.1.2-3fixed
stretch1.2.0-3fixed
buster, sid1.2.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mysql-ocamlsource(unstable)1.0.4-7low
mysql-ocamlsourceetch1.0.4-2+etch1highDSA-1910-1
mysql-ocamlsourcelenny1.0.4-4+lenny1highDSA-1910-1

Search for package or bug name: Reporting problems