CVE-2009-2947

NameCVE-2009-2947
DescriptionCross-site scripting (XSS) vulnerability in Xapian Omega before 1.0.16 allows remote attackers to inject arbitrary web script or HTML via unspecified CGI parameter values, which are sometimes included in exception messages.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1882-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xapian-omega (PTS)stretch1.4.3-3fixed
buster1.4.11-1fixed
bookworm, sid, bullseye1.4.18-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xapian-omegasourceetch0.9.9-1+etch1DSA-1882-1
xapian-omegasourcelenny1.0.7-3+lenny1DSA-1882-1
xapian-omegasource(unstable)1.0.15-2

Search for package or bug name: Reporting problems