CVE-2009-3272

NameCVE-2009-3272
DescriptionStack consumption vulnerability in WebKit.dll in WebKit in Apple Safari 3.2.3, and possibly other versions before 4.1.2, allows remote attackers to cause a denial of service (application crash) via JavaScript code that calls eval on a long string composed of A/ sequences.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde4libs (PTS)wheezy4:4.8.4-4+deb7u1vulnerable
wheezy (security)4:4.8.4-4+deb7u3vulnerable
jessie (security), jessie4:4.14.2-5+deb8u2vulnerable
stretch4:4.14.26-2vulnerable
buster, sid4:4.14.36-1vulnerable
qt4-x11 (PTS)wheezy4:4.8.2+dfsg-11vulnerable
jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1vulnerable
buster, sid, stretch4:4.8.7+dfsg-11vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kde4libssource(unstable)(unfixed)unimportant
kdelibssource(unstable)(unfixed)unimportant
qt4-x11source(unstable)(unfixed)unimportant
qt4-x11sourceetch(not affected)

Notes

[etch] - qt4-x11 <not-affected> (webkit support introduced in version 4.4)
browser crashers are not considered security-relevant

Search for package or bug name: Reporting problems