CVE-2009-3291

NameCVE-2009-3291
DescriptionThe php_openssl_apply_verification_policy function in PHP before 5.2.11 does not properly perform certificate validation, which has unknown impact and attack vectors, probably related to an ability to spoof certificates.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1940-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)squeeze, squeeze (security)5.3.3-7+squeeze19fixed
squeeze (lts)5.3.3.1-7+squeeze26fixed
wheezy5.4.36-0+deb7u1fixed
wheezy (security)5.4.41-0+deb7u1fixed
jessie5.6.7+dfsg-1fixed
jessie (security)5.6.9+dfsg-0+deb8u1fixed
stretch, sid5.6.9+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.2.11.dfsg.1-1low
php5sourceetch5.2.0+dfsg-8+etch16highDSA-1940-1
php5sourcelenny5.2.6.dfsg.1-1+lenny4highDSA-1940-1

Notes

[lenny] - php5 <no-dsa> (rather unimportant)
[etch] - php5 <no-dsa> (rather unimportant)
seems to be related to handling of \0 on CN
not worth a dsa on its own, php doesn't verify certificates by default
experimental is likely to be affected (as of 5.3.0)

Search for package or bug name: Reporting problems