CVE-2009-3384

NameCVE-2009-3384
DescriptionMultiple unspecified vulnerabilities in WebKit in Apple Safari before 4.0.4 on Windows allow remote FTP servers to execute arbitrary code, cause a denial of service (application crash), or obtain sensitive information via a crafted directory listing in a reply.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs559759, 561760

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kde4libs (PTS)jessie4:4.14.2-5+deb8u2fixed
jessie (security)4:4.14.2-5+deb8u3fixed
stretch4:4.14.26-2fixed
buster4:4.14.38-3fixed
qt4-x11 (PTS)jessie4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u1fixed
jessie (security)4:4.8.6+git64-g5dc8b2b+dfsg-3+deb8u2fixed
stretch4:4.8.7+dfsg-11fixed
buster4:4.8.7+dfsg-18fixed
bullseye, sid4:4.8.7+dfsg-19fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kde4libssource(unstable)(not affected)
kdelibssource(unstable)(not affected)
qt4-x11source(unstable)4:4.6.2-4561760
qt4-x11sourceetch(not affected)
webkitsource(unstable)1.1.17-2medium559759

Notes

[lenny] - webkit <no-dsa> (Unmaintained in Lenny, only affects fringe apps)
[lenny] - qt4-x11 <no-dsa> (Minor impact, no apps in Lenny which use qtwebkit )
QT4 might be fixed earlier, but only 4.6.2 was checked against, Lenny is affected
[etch] - qt4-x11 <not-affected> (webkit support introduced in version 4.4)
- kdelibs <not-affected> (vulnerable code not present)
- kde4libs <not-affected> (vulnerable code not present)
http://trac.webkit.org/changeset/48725

Search for package or bug name: Reporting problems