CVE-2009-3490

NameCVE-2009-3490
DescriptionGNU Wget before 1.12 does not properly handle a '\0' character in a domain name in the Common Name field of an X.509 certificate, which allows man-in-the-middle remote attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority, a related issue to CVE-2009-2408.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1904-1
NVD severitymedium (attack range: remote)
Debian Bugs549293

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wget (PTS)wheezy1.13.4-3+deb7u2fixed
wheezy (security)1.13.4-3+deb7u4fixed
jessie1.16-1+deb8u2fixed
stretch1.18-5fixed
buster, sid1.19.1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wgetsource(unstable)1.12-1medium549293
wgetsourceetch1.10.2-2+etch1mediumDSA-1904-1
wgetsourcelenny1.11.4-2+lenny1mediumDSA-1904-1

Search for package or bug name: Reporting problems