CVE-2009-3606

NameCVE-2009-3606
DescriptionInteger overflow in the PSOutputDev::doImageL1Sep function in Xpdf before 3.02pl4, and Poppler 0.x, as used in kdegraphics KPDF, might allow remote attackers to execute arbitrary code via a crafted PDF document that triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1941-1, DSA-2028-1, DSA-2050-1
NVD severityhigh (attack range: remote)
Debian Bugs551287, 551289, 551290

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
poppler (PTS)wheezy0.18.4-6fixed
wheezy (security)0.18.4-6+deb7u3fixed
jessie (security), jessie0.26.5-2+deb8u1fixed
stretch0.48.0-2fixed
buster, sid0.57.0-2fixed
swftools (PTS)wheezy0.9.2+ds1-3fixed
wheezy (security)0.9.2+ds1-3+deb7u1fixed
jessie0.9.2+git20130725-2fixed
buster, sid, stretch0.9.2+git20130725-4.1fixed
xpdf (PTS)wheezy3.03-10fixed
jessie3.03-17fixed
buster, sid, stretch3.04-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kdegraphicssource(unstable)4:4.0medium551290
kdegraphicssourcelenny4:3.5.9-3+lenny3highDSA-2050-1
popplersource(unstable)0.12.2-1medium551289
popplersourcelenny0.8.7-3highDSA-1941-1
swftoolssource(unstable)0.9.2+ds1-2high
xpdfsource(unstable)3.02-2medium551287
xpdfsourcelenny3.02-1.4+lenny2highDSA-2028-1

Search for package or bug name: Reporting problems