CVE-2009-3638

NameCVE-2009-3638
DescriptionInteger overflow in the kvm_dev_ioctl_get_supported_cpuid function in arch/x86/kvm/x86.c in the KVM subsystem in the Linux kernel before 2.6.31.4 allows local users to have an unspecified impact via a KVM_GET_SUPPORTED_CPUID request to the kvm_arch_dev_ioctl function.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1927-1, DSA-1962-1
NVD severityhigh (attack range: local)
Debian Bugs562076
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze (security), squeeze2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kvmsource(unstable)(unfixed)medium562076
kvmsourcelenny72+dfsg-5~lenny4highDSA-1962-1
linux-2.6source(unstable)2.6.31-1medium
linux-2.6sourceetch(not affected)
linux-2.6sourcelenny2.6.26-19lenny2highDSA-1927-1
linux-2.6.24source(unstable)(not affected)

Notes

[etch] - linux-2.6 <not-affected> (introduced in 2.6.25)
fixed in upstream 2.6.32-rc4
- linux-2.6.24 <not-affected> (introduced in 2.6.25)

Search for package or bug name: Reporting problems