CVE-2009-3695

NameCVE-2009-3695
DescriptionAlgorithmic complexity vulnerability in the forms library in Django 1.0 before 1.0.4 and 1.1 before 1.1.1 allows remote attackers to cause a denial of service (CPU consumption) via a crafted (1) EmailField (email address) or (2) URLField (URL) that triggers a large amount of backtracking in a regular expression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1905-1
NVD severitymedium (attack range: remote)
Debian Bugs550457

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-django (PTS)wheezy1.4.5-1+deb7u16fixed
wheezy (security)1.4.22-1+deb7u3fixed
jessie (security), jessie1.7.11-1+deb8u2fixed
stretch1:1.10.7-2fixed
buster, sid1:1.11.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-djangosource(unstable)1.1.1-1medium550457
python-djangosourceetch(not affected)
python-djangosourcelenny1.0.2-1+lenny2medium

Notes

[etch] - python-django <not-affected> (introduced in 1.0)

Search for package or bug name: Reporting problems