CVE-2009-3697

NameCVE-2009-3697
DescriptionSQL injection vulnerability in the PDF schema generator functionality in phpMyAdmin 2.11.x before 2.11.9.6 and 3.x before 3.2.2.1 allows remote attackers to execute arbitrary SQL commands via unspecified interface parameters.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1918-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
phpmyadmin (PTS)squeeze, squeeze (security)4:3.3.7-7fixed
squeeze (lts)4:3.3.7-8fixed
wheezy (security), wheezy4:3.4.11.1-2+deb7u1fixed
jessie4:4.2.12-2fixed
stretch, sid4:4.4.14-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
phpmyadminsource(unstable)4:3.2.2.1-1high
phpmyadminsourceetch4:2.9.1.1-13highDSA-1918-1
phpmyadminsourcelenny4:2.11.8.1-5+lenny3highDSA-1918-1

Notes

[etch] - phpmyadmin <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems