CVE-2009-3725

NameCVE-2009-3725
DescriptionThe connector layer in the Linux kernel before 2.6.31.5 does not require the CAP_SYS_ADMIN capability for certain interaction with the (1) uvesafb, (2) pohmelfs, (3) dst, or (4) dm subsystem, which allows local users to bypass intended access restrictions and gain privileges via calls to functions in these subsystems.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2012-1
NVD severityhigh (attack range: local)

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6source(unstable)2.6.31-1medium
linux-2.6sourceetch(not affected)
linux-2.6sourcelenny2.6.26-21lenny4highDSA-2012-1
linux-2.6.24source(unstable)(unfixed)medium

Notes

[etch] - linux-2.6 <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems