CVE-2009-3889

NameCVE-2009-3889
DescriptionThe dbg_lvl file for the megaraid_sas driver in the Linux kernel before 2.6.27 has world-writable permissions, which allows local users to change the (1) behavior and (2) logging level of the driver by modifying this file.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-2005-1
NVD severitymedium (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot known to be vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze, squeeze (security)2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze13fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linux-2.6source(unstable)2.6.27-1low
linux-2.6sourceetch(not affected)
linux-2.6sourcelenny2.6.26-21medium
linux-2.6.24source(unstable)(unfixed)low
linux-2.6.24sourceetch2.6.24-6~etchnhalf.9etch3mediumDSA-2005-1

Notes

[etch] - linux-2.6 <not-affected> (Vulnerable code not present)

Search for package or bug name: Reporting problems