CVE-2009-4008

NameCVE-2009-4008
DescriptionUnbound before 1.4.4 does not send responses for signed zones after mishandling an unspecified query, which allows remote attackers to cause a denial of service (DNSSEC outage) via a crafted query.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2243-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unbound (PTS)wheezy, wheezy (security)1.4.17-3+deb7u2fixed
jessie1.4.22-3+deb8u2fixed
stretch1.6.0-3+deb9u1fixed
buster1.6.6-1fixed
sid1.6.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unboundsource(unstable)1.4.4-1low
unboundsourcelenny1.4.6-1~lenny1mediumDSA-2243-1

Search for package or bug name: Reporting problems