CVE-2009-4009

NameCVE-2009-4009
DescriptionBuffer overflow in PowerDNS Recursor before 3.1.7.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via crafted packets.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1968-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns-recursor (PTS)buster, buster (security)4.1.11-1+deb10u1fixed
bullseye4.4.2-3fixed
bookworm4.8.4-1fixed
bookworm (security)4.8.8-1fixed
sid, trixie5.0.5-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdns-recursorsourceetch(not affected)
pdns-recursorsourcelenny3.1.7-1+lenny1DSA-1968-1
pdns-recursorsource(unstable)3.1.7.2-1high

Notes

[etch] - pdns-recursor <not-affected> (vulnerable code not present)

Search for package or bug name: Reporting problems