CVE-2009-4010

NameCVE-2009-4010
DescriptionUnspecified vulnerability in PowerDNS Recursor before 3.1.7.2 allows remote attackers to spoof DNS data via crafted zones.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1968-1, DSA-1968-2
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns-recursor (PTS)squeeze3.2-4fixed
squeeze (lts)3.2-4+deb6u1fixed
wheezy, wheezy (security)3.3-3+deb7u1fixed
jessie3.6.2-2+deb8u1fixed
jessie (security)3.6.2-2+deb8u2fixed
stretch, sid3.7.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdns-recursorsource(unstable)3.1.7.2-1high
pdns-recursorsourceetch3.1.4+v3.1.7-0+etch1highDSA-1968-2
pdns-recursorsourcelenny3.1.7-1+lenny1highDSA-1968-1

Search for package or bug name: Reporting problems