CVE-2009-4011

NameCVE-2009-4011
Descriptiondtc-xen 0.5.x before 0.5.4 suffers from a race condition where an attacker could potentially get a bash access as xenXX user on the dom0, and then access a potentially reuse an already opened VPS console.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dtc-xen (PTS)jessie, stretch0.5.17-1fixed
buster0.5.17-1.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dtc-xensource(unstable)0.5.4-1
dtc-xensourcelenny(not affected)

Notes

[lenny] - dtc-xen <not-affected> (Only affects 0.5.x)

Search for package or bug name: Reporting problems