CVE-2009-4012

NameCVE-2009-4012
DescriptionMultiple integer overflows in LibThai before 0.1.13 might allow context-dependent attackers to execute arbitrary code via long strings that trigger heap-based buffer overflows, related to (1) thbrk/thbrk.c and (2) thwbrk/thwbrk.c. NOTE: some of these details are obtained from third party information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1971-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libthai (PTS)wheezy0.1.18-2fixed
jessie0.1.21-1fixed
stretch0.1.26-1fixed
buster, sid0.1.26-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libthaisource(unstable)0.1.13-1high
libthaisourceetch0.1.6-1+etch1highDSA-1971-1
libthaisourcelenny0.1.9-4+lenny1highDSA-1971-1

Search for package or bug name: Reporting problems