CVE-2009-4015

NameCVE-2009-4015
DescriptionLintian 1.23.x through 1.23.28, 1.24.x through 1.24.2.1, and 2.x before 2.3.2 allows remote attackers to execute arbitrary commands via shell metacharacters in filename arguments.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1979-1
NVD severityhigh (attack range: remote)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
lintian (PTS)squeeze2.4.3+squeeze1fixed
wheezy2.5.10.4fixed
sid, stretch, jessie2.5.30+deb8u4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
lintiansource(unstable)2.3.2medium
lintiansourceetch1.23.28+etch1highDSA-1979-1
lintiansourcelenny1.24.2.1+lenny1highDSA-1979-1

Search for package or bug name: Reporting problems