CVE-2009-4128

NameCVE-2009-4128
DescriptionGNU GRand Unified Bootloader (GRUB) 2 1.97 only compares the submitted portion of a password with the actual password, which makes it easier for physically proximate attackers to conduct brute force attacks and bypass authentication by submitting a password whose length is 1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs555195

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
grub (PTS)bullseye0.97-77fixed
bookworm0.97-80fixed
sid, trixie0.97-82fixed
grub2 (PTS)bullseye (security), bullseye2.06-3~deb11u6fixed
bookworm, bookworm (security)2.06-13+deb12u1fixed
trixie2.12-2fixed
sid2.12-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
grubsource(unstable)(not affected)
grub2sourcelenny(not affected)
grub2source(unstable)1.97+20091115-1555195

Notes

[lenny] - grub2 <not-affected> (Password authentication not yet present)
- grub <not-affected> (only affects grub2)

Search for package or bug name: Reporting problems