CVE-2009-4136

NameCVE-2009-4136
DescriptionPostgreSQL 7.4.x before 7.4.27, 8.0.x before 8.0.23, 8.1.x before 8.1.19, 8.2.x before 8.2.15, 8.3.x before 8.3.9, and 8.4.x before 8.4.2 does not properly manage session-local state during execution of an index function by a database superuser, which allows remote authenticated users to gain privileges via a table with crafted index functions, as demonstrated by functions that modify (1) search_path or (2) a prepared statement, a related issue to CVE-2007-6600 and CVE-2009-3230.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1964-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
postgresql-8.4 (PTS)wheezy8.4.22-0+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
postgresql-7.4source(unstable)(unfixed)medium
postgresql-7.4sourceetch1:7.4.27-0etch1mediumDSA-1964-1
postgresql-8.1source(unstable)(unfixed)medium
postgresql-8.1sourceetch8.1.19-0etch1mediumDSA-1964-1
postgresql-8.2source(unstable)(unfixed)medium
postgresql-8.3source(unstable)8.3.9-1low
postgresql-8.3sourcelenny8.3.9-0lenny1mediumDSA-1964-1
postgresql-8.4source(unstable)8.4.2-1low

Search for package or bug name: Reporting problems