CVE-2009-4142

NameCVE-2009-4142
DescriptionThe htmlspecialchars function in PHP before 5.2.12 does not properly handle (1) overlong UTF-8 sequences, (2) invalid Shift_JIS sequences, and (3) invalid EUC-JP sequences, which allows remote attackers to conduct cross-site scripting (XSS) attacks by placing a crafted byte sequence before a special character.
SourceCVE (at NVD; LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-2001-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy (security), wheezy5.4.45-0+deb7u2fixed
jessie5.6.19+dfsg-0+deb8u1fixed
jessie (security)5.6.20+dfsg-0+deb8u1fixed
stretch5.6.21+dfsg-2fixed
sid5.6.22+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.2.12.dfsg.1-1medium
php5sourcelenny5.2.6.dfsg.1-1+lenny6mediumDSA-2001-1

Search for package or bug name: Reporting problems