CVE-2009-4212

NameCVE-2009-4212
DescriptionMultiple integer underflows in the (1) AES and (2) RC4 decryption functionality in the crypto library in MIT Kerberos 5 (aka krb5) 1.3 through 1.6.3, and 1.7 before 1.7.1, allow remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code by providing ciphertext with a length that is too short to be valid.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1969-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
krb5 (PTS)wheezy1.10.1+dfsg-5+deb7u7fixed
wheezy (security)1.10.1+dfsg-5+deb7u8fixed
jessie (security), jessie1.12.1+dfsg-19+deb8u2fixed
stretch1.15-1+deb9u1fixed
buster, sid1.15.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
krb5source(unstable)1.8+dfsg~alpha1-1high
krb5sourceetch1.4.4-7etch8highDSA-1969-1
krb5sourcelenny1.6.dfsg.4~beta1-5lenny2highDSA-1969-1

Search for package or bug name: Reporting problems